<!doctype html>
<!--[if lt IE 7]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js"><!--<![endif]-->
	<head>
		<meta charset="utf-8">
		
		
		
				<meta name="HandheldFriendly" content="True">
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0">
		
		<!-- So the site runs in fullscreen when launched from a devices homescreen -->
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		
				<link rel="apple-touch-icon" href="http://thegriff.ca/wp-content/themes/bones/images/apple-icon-touch.png">
		<link rel="icon" href="http://thegriff.ca/wp-content/themes/bones/favicon.png?1">
		<!--[if IE]>
			<link rel="shortcut icon" href="http://thegriff.ca/wp-content/themes/bones/favicon.ico">
		<![endif]-->
				<meta name="msapplication-TileColor" content="#f01d4f">
		<meta name="msapplication-TileImage" content="http://thegriff.ca/wp-content/themes/bones/images/win8-tile-icon.png">
		
		<link rel="pingback" href="http://thegriff.ca/xmlrpc.php">
		
				
<!-- This site is optimized with the Yoast SEO plugin v3.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>MacEwan-made funk takes over The Needle | The Griff</title>
<meta name="description" content="“That was arguably one of the best shows I’ve ever been to.”"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://thegriff.ca/2017/01/macewan-made-funk-takes-needle/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="MacEwan-made funk takes over The Needle | The Griff" />
<meta property="og:description" content="“That was arguably one of the best shows I’ve ever been to.”" />
<meta property="og:url" content="http://thegriff.ca/2017/01/macewan-made-funk-takes-needle/" />
<meta property="og:site_name" content="The Griff" />
<meta property="article:tag" content="band" />
<meta property="article:tag" content="carter &amp; the capitals" />
<meta property="article:tag" content="Music" />
<meta property="article:tag" content="the needle vinyl tavern" />
<meta property="article:section" content="Events" />
<meta property="article:published_time" content="2017-01-24T16:40:10-07:00" />
<meta property="og:image" content="http://thegriff.ca/wp-content/uploads/2017/01/Carter2.jpg" />
<meta property="og:image:width" content="7952" />
<meta property="og:image:height" content="5304" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="“That was arguably one of the best shows I’ve ever been to.”" />
<meta name="twitter:title" content="MacEwan-made funk takes over The Needle | The Griff" />
<meta name="twitter:image" content="http://thegriff.ca/wp-content/uploads/2017/01/Carter2.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s.w.org'>
<link rel="alternate" type="application/rss+xml" title="The Griff &raquo; Feed" href="http://thegriff.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Griff &raquo; Comments Feed" href="http://thegriff.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Griff &raquo; MacEwan-made funk takes over The Needle Comments Feed" href="http://thegriff.ca/2017/01/macewan-made-funk-takes-needle/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thegriff.ca\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='realtidbitsPushquote_headcss-css'  href='http://thegriff.ca/wp-content/plugins/kobot-pushquote/css/pullquote.css' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='http://thegriff.ca/wp-content/themes/bones/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='http://thegriff.ca/wp-content/themes/bones/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='http://thegriff.ca/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.2 - Universal enabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-68593567-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://thegriff.ca/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://thegriff.ca/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PushquoteAjax = {"show_credits":"","login":null,"api_key":null};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegriff.ca/wp-content/plugins/kobot-pushquote/js/pullquote.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegriff.ca/wp-content/plugins/jetpack/modules/related-posts/related-posts.js'></script>
<script type='text/javascript' src='http://thegriff.ca/wp-content/themes/bones/js/libs/modernizr.custom.min.js'></script>
<link rel='https://api.w.org/' href='http://thegriff.ca/wp-json/' />
<link rel='shortlink' href='http://wp.me/p6AgSP-6Wy' />
<link rel="alternate" type="application/json+oembed" href="http://thegriff.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegriff.ca%2F2017%2F01%2Fmacewan-made-funk-takes-needle%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thegriff.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegriff.ca%2F2017%2F01%2Fmacewan-made-funk-takes-needle%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>				<script src="//use.typekit.net/owl7wnu.js"></script>
		<script>try{Typekit.load({ async: true });}catch(e){}</script>
		
	</head>
	<body class="single single-post postid-26694 single-format-standard post-macewan-made-funk-takes-needle">
		<div id="container">
			<header id="page-header" role="banner">
				<div class="top-logo">
										<h1><a href="http://thegriff.ca" rel="nofollow">The Griff</a></h1>
					<div class="navHamburger">&equiv;</div>
				</div>
			</header>
			
			<header class="titleheader">
				<div class="title-block">
					<h1><a href="http://thegriff.ca" rel="nofollow">The Griff</a></h1>
					<ul class="sticky-nav">
						<li class="search-link">Search </li>
						<li class="navHamburger">Menu <span>&equiv;</span></li>
					</ul>
				</div>
								<div class="contextual-block">
					<h2>MacEwan-made funk takes over The Needle</h2>
				</div>
						</header>
			
			<nav id="main-nav">
				<div class="wrap">
										<div class="nav-block">
						<div class="nav-level-1">
							<div class="nav-masthead">
								<p class="tagline">griff, n. (19th c. slang): a tip; reliable information. The Griff is MacEwan University&#039;s student media, est. 2011. Daily online. Monthly in print.</p>
							</div>
							<div class="nav-social">
																<ul>
									<li class="icon-social-facebook"><a href="https://facebook.com/thegriffmag" class="footer-social-facebook">/thegriffmag</a></li>									<li class="icon-social-twitter"><a href="https://twitter.com/thegriffmag" class="footer-social-twitter">@thegriffmag</a></li>									<li class="icon-social-instagram"><a href="https://instagram.com/thegriffmag" class="footer-social-instagram">thegriffmag</a></li>									<li class="icon-social-mail"><a href="mailto:info@thegriff.ca" class="footer-social-email">info@thegriff.ca</a></li>								</ul>
							</div>
						</div>
						<div class="nav-level-2">
							<div class="nav-categories">
								<h2>Categories</h2>
								<ul>
										<li class="cat-item cat-item-4"><a href="http://thegriff.ca/category/campus/" >Campus</a>
</li>
	<li class="cat-item cat-item-2"><a href="http://thegriff.ca/category/culture/" >Culture</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://thegriff.ca/category/downtown/" >Downtown</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://thegriff.ca/category/education/" >Education</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://thegriff.ca/category/events/" >Events</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://thegriff.ca/category/food/" >Food</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://thegriff.ca/category/lifestyle/" >Lifestyle</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://thegriff.ca/category/news/" >News</a>
</li>
	<li class="cat-item cat-item-6080"><a href="http://thegriff.ca/category/newsletter/" >Newsletter</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://thegriff.ca/category/opinions/" >Opinions</a>
</li>
	<li class="cat-item cat-item-6079"><a href="http://thegriff.ca/category/other/" >Other</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://thegriff.ca/category/people/" >People</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://thegriff.ca/category/politics/" >Politics</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://thegriff.ca/category/sports/" >Sports</a>
</li>
								</ul>
							</div>
							<div class="nav-pop">
								<h2>Quick Links</h2>
								<ul>
									<li><a href="/contact">Contact</a></li>
									<li><a href="/about">About</a></li>
									<li><a href="/volunteer">Volunteer</a></li>
									<li><a href="/latest">Latest</a></li>
									<li><a href="/most-popular">Popular</a></li>
								</ul>
							</div>
							<div class="search-block">
								<h2>Search</h2>
								<form role="search" method="get" id="searchform" action="http://thegriff.ca/" >
	<!--<label class="screen-reader-text" for="s">Search for:</label>-->
	<input type="text" value="" name="s" id="s" placeholder="Search the Site..." />
	<input type="submit" id="searchsubmit" value="Search" />
	</form>							</div>
						</div>
					</div>
				</div>
			</nav>			<div id="content">
																		<style type="text/css" media="screen">
						#content #blog-intro{
							background-image: url(http://thegriff.ca/wp-content/uploads/2017/01/Carter2-1800x1200.jpg);
						}
					</style>
									<article id="blog-26694" class="post-26694 post type-post status-publish format-standard has-post-thumbnail hentry category-events tag-band tag-carter-the-capitals tag-music tag-the-needle-vinyl-tavern" role="article" itemscope itemtype="http://schema.org/BlogPosting">
						<section id="blog-intro" class="intro-block feature-image peakheight">
							<div class="wrap block-content">
								<p class="category"><a href="http://thegriff.ca/category/events/" rel="category tag">Events</a></p>
								<h1>MacEwan-made funk takes over The Needle</h1>
																<div class="deck">Carter & the Capitals shake things up with the release of their new single</div>								<div class="article-meta">
									<p class="author"><a href="http://thegriff.ca/author/emily-ireland/" title="Posts by Emily Ireland" class="author url fn" rel="author">Emily Ireland</a></p>
									<p class="date"><time class="updated" datetime="2017-01-24" pubdate>January 24, 2017</time></p>
								</div>
							</div>
						</section>
						<section id="blog-content" itemprop="articleBody">
							<div class="wrap">
								<p><span style="font-weight: 400;">The walls of The Needle Vinyl Tavern pulsed with the heartbeat of funk music on Jan. 20, when Carter &amp; the Capitals performed to celebrate the release of their newest single “</span><em><a href="https://play.spotify.com/album/223uIlDhYplbJdoYz0AleA" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://play.spotify.com/album/223uIlDhYplbJdoYz0AleA', 'Get Down');"><span style="font-weight: 400;">Get Down</span></a></em><span style="font-weight: 400;">”</span><i><span style="font-weight: 400;">.</span></i></p><div class="blog-body-wide-ad-block">
	<!-- Griff - Bottom Banner [async] -->
	<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ab166973.adbutler-meson.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
	<script type="text/javascript">
	var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
	var abkw = window.abkw || '';
	var plc188830 = window.plc188830 || 0;
	document.write('<div id="placement_188830_'+plc188830+'"></div>');
	AdButler.ads.push({handler: function(opt){ AdButler.register(166973, 188830, [728,90], 'placement_188830_'+opt.place, opt); }, opt: { place: plc188830++, keywords: abkw, domain: 'ab166973.adbutler-meson.com' }});
	</script>
</div>
<p><span style="font-weight: 400;">The group came together two years ago in the classrooms of the CFAC building during the band members’ second year in the Bachelor of Music program, and their careers have been on a steady incline ever since. </span></p><p><span style="font-weight: 400;">The members come from diverse musical backgrounds, and together they produce a funk/soul sound that is impossible to ignore. The release of “<em>Get Down</em>” follows the success of their sexy, slow-burn single “</span><em><a href="https://soundcloud.com/carter-the-capitals/take-you-for-a-ride" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://soundcloud.com/carter-the-capitals/take-you-for-a-ride', 'Take You for a Ride');"><span style="font-weight: 400;">Take You for a Ride</span></a></em><span style="font-weight: 400;">”,</span> <span style="font-weight: 400;">released in the fall of 2016. </span></p><p><span style="font-weight: 400;">“<em>Get Down</em>”</span> <span style="font-weight: 400;">offers a sound that is the product of the group’s attention to classic funk, which produced a punchy single that pays tribute to the origins of the genre while adding a modern twist.</span></p><p><span style="font-weight: 400;">“For us, it’s a showcase of the work we put into listening to all the nuances and subtleties of older funk music,” said frontman Lindon Carter. “We ended up actually stripping a lot down to make it more simplified, just showing that we understand the important subtleties of classic funk music.”</span></p><p><span style="font-weight: 400;">The show was kicked off by The Torchettes, a duo hailing from Calgary. Although it was the group’s first time performing in Edmonton, they were welcomed with open arms. They warmed the crowd up with a set that was filled to the brim with classic rock and soul music, adding their own personal flare that definitely left  a lasting impression.</span></p>
<hr />
<figure id="attachment_26698" style="width: 1024px;" class="wp-caption alignnone  wp-image-26698 size-large"><img class="" src="http://thegriff.ca/wp-content/uploads/2017/01/Carter1-1024x683.jpg" alt="Carter1" width="1024" height="683" srcset="http://thegriff.ca/wp-content/uploads/2017/01/Carter1-1024x683.jpg 1024w, http://thegriff.ca/wp-content/uploads/2017/01/Carter1-300x200.jpg 300w, http://thegriff.ca/wp-content/uploads/2017/01/Carter1-768x512.jpg 768w, http://thegriff.ca/wp-content/uploads/2017/01/Carter1-1100x733.jpg 1100w, http://thegriff.ca/wp-content/uploads/2017/01/Carter1-700x466.jpg 700w, http://thegriff.ca/wp-content/uploads/2017/01/Carter1-600x400.jpg 600w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Photo by Barnaba Siwila.</figcaption></figure>
<hr /><p><span style="font-weight: 400;">The tavern was buzzing with anticipation when Carter &amp; the Capitals hit the stage, opening with “</span><em><a href="https://soundcloud.com/carter-the-capitals/guilty" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://soundcloud.com/carter-the-capitals/guilty', 'Guilty');"><span style="font-weight: 400;">Guilty</span></a></em><span style="font-weight: 400;">”, which had everyone on their feet and dancing right out of the gate. The band brought an energy to the stage that truly set them apart from other artists, which Carter said is a product of the group’s love for the music they’re playing.</span></p><p><span style="font-weight: 400;">“It’s definitely a genuine thing,” he said. “The energy just comes out of genuinely enjoying what we’re doing.”</span></p><p><span style="font-weight: 400;">After warming up with a few of their earlier songs, the band busted out their new single. The crowd sang along, which was an obvious indicator of the group’s strong fan base in their hometown, and something that Carter said the band truly appreciates.</span></p><p><span style="font-weight: 400;">“We know how to bring the energy up and get the audience that maybe doesn’t know us,” said Carter. “But what I’m excited about for tonight is showing up and having people that know what we’re all about.”</span></p><p><span style="font-weight: 400;">After the group closed the show with an unforgettable encore that included a one-of-a-kind cover of Childish Gambino’s “<em>Redbone</em>”, concert-goer Ben Hollihan had nothing but positive things to say about the show as the crowd slowly trickled out of the venue.</span></p><p><span style="font-weight: 400;">“That was arguably one of the best shows I’ve ever been to,” said Hollihan. “They tell you what they want you to do, get down! And people listened, it was fantastic.”</span></p><p><span style="font-weight: 400;">Following what is sure to be the successful release of “<em>Get Down</em>”, the group will be filming a music video for the single in the near future while they prepare to graduate in the spring.</span></p><p><span style="font-weight: 400;">For those who missed the single release party, Carter &amp; the Capitals will be headlining The Rec Room on Saturday, Feb. 25.</span></p>
<hr />
<p><em>Cover photo by <span class="s1">Barnaba Siwila.</span></em></p>
							</div>
						</section>
						
						<footer class="entry-meta wrap">
							<div class="entry-meta-details post-byline">
								<section class="staff-member">
									<div class="staff-details">
										<h1><a href="http://thegriff.ca/author/emily-ireland/" title="Posts by Emily Ireland" class="author url fn" rel="author">Emily Ireland</a></h1>
										<p class="post-date">Posted <time class="updated" datetime="2017-01-24">January 24, 2017</time></p>
										<p class="post-category">Categories: <a href="http://thegriff.ca/category/events/" rel="category tag">Events</a></p>									
									</div>
								</section>
							</div>
							<div class="blog-ad-wide">
								<!-- Griff - Bottom Banner [async] -->
								<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ab166973.adbutler-meson.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
								<script type="text/javascript">
								var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
								var abkw = window.abkw || '';
								var plc188830 = window.plc188830 || 0;
								document.write('<'+'div id="placement_188830_'+plc188830+'"></'+'div>');
								AdButler.ads.push({handler: function(opt){ AdButler.register(166973, 188830, [728,90], 'placement_188830_'+opt.place, opt); }, opt: { place: plc188830++, keywords: abkw, domain: 'ab166973.adbutler-meson.com' }});
								</script>
							</div>
							<!-- <div class="tag-links">
								<p></p>
							</div>-->
						</footer>
						
						<footer id="more-posts" class="keep-reading wrap">
							<div id="related-posts">
								<h2>Related Posts</h2>
								<section class="list-view">
																	</section>
							</div>
							<div id="popular-posts">
								<h2>Popular Posts</h2>
								<section class="three-wide">
									hello!<article><div class="block-image"><a href="http://thegriff.ca/2016/09/drugs-wont-make-favourite-rapper-great/"><img width="600" height="400" src="http://thegriff.ca/wp-content/uploads/2016/08/Drugs2_JaculaMatthew-600x400.png" class="attachment-feature-thumb-small size-feature-thumb-small wp-post-image" alt="Drugs2_JaculaMatthew" srcset="http://thegriff.ca/wp-content/uploads/2016/08/Drugs2_JaculaMatthew-600x400.png 600w, http://thegriff.ca/wp-content/uploads/2016/08/Drugs2_JaculaMatthew-1100x733.png 1100w, http://thegriff.ca/wp-content/uploads/2016/08/Drugs2_JaculaMatthew-700x466.png 700w" sizes="(max-width: 600px) 100vw, 600px" /></a></div><div class="block-content"><h1><a href="http://thegriff.ca/2016/09/drugs-wont-make-favourite-rapper-great/">Drugs won’t make your favourite rapper great again</a></h1><div class="deck">Addiction and music don't have to be mutually exclusive</div><div class="article-meta"><p class="author"><a href="http://thegriff.ca/author/jibril-yassin/" title="Posts by Jibril Yassin" class="author url fn" rel="author">Jibril Yassin</a></p><p class="date"><time class="updated" datetime="2016-09-7" pubdate>September 7, 2016</time></p></div></div></article><article><div class="block-image"><a href="http://thegriff.ca/2017/01/students-get-opportunity-step-shoes-executive/"><img width="600" height="400" src="http://thegriff.ca/wp-content/uploads/2017/01/samu-600x400.png" class="attachment-feature-thumb-small size-feature-thumb-small wp-post-image" alt="samu" srcset="http://thegriff.ca/wp-content/uploads/2017/01/samu-600x400.png 600w, http://thegriff.ca/wp-content/uploads/2017/01/samu-1100x733.png 1100w, http://thegriff.ca/wp-content/uploads/2017/01/samu-700x466.png 700w" sizes="(max-width: 600px) 100vw, 600px" /></a></div><div class="block-content"><h1><a href="http://thegriff.ca/2017/01/students-get-opportunity-step-shoes-executive/">Students get the opportunity to step into the shoes of an executive</a></h1><div class="article-meta"><p class="author"><a href="http://thegriff.ca/author/aubrianna-broughton/" title="Posts by Aubrianna Broughton" class="author url fn" rel="author">Aubrianna Broughton</a></p><p class="date"><time class="updated" datetime="2017-01-24" pubdate>January 24, 2017</time></p></div></div></article><article><div class="block-image"><a href="http://thegriff.ca/2017/01/macewan-made-funk-takes-needle/"><img width="600" height="400" src="http://thegriff.ca/wp-content/uploads/2017/01/Carter2-600x400.jpg" class="attachment-feature-thumb-small size-feature-thumb-small wp-post-image" alt="Carter2" srcset="http://thegriff.ca/wp-content/uploads/2017/01/Carter2-600x400.jpg 600w, http://thegriff.ca/wp-content/uploads/2017/01/Carter2-300x200.jpg 300w, http://thegriff.ca/wp-content/uploads/2017/01/Carter2-768x512.jpg 768w, http://thegriff.ca/wp-content/uploads/2017/01/Carter2-1024x683.jpg 1024w, http://thegriff.ca/wp-content/uploads/2017/01/Carter2-1100x733.jpg 1100w, http://thegriff.ca/wp-content/uploads/2017/01/Carter2-700x466.jpg 700w" sizes="(max-width: 600px) 100vw, 600px" /></a></div><div class="block-content"><h1><a href="http://thegriff.ca/2017/01/macewan-made-funk-takes-needle/">MacEwan-made funk takes over The Needle</a></h1><div class="deck">Carter & the Capitals shake things up with the release of their new single</div><div class="article-meta"><p class="author"><a href="http://thegriff.ca/author/emily-ireland/" title="Posts by Emily Ireland" class="author url fn" rel="author">Emily Ireland</a></p><p class="date"><time class="updated" datetime="2017-01-24" pubdate>January 24, 2017</time></p></div></div></article><article><div class="block-image"><a href="http://thegriff.ca/2017/01/fiction-campus-beyond/"><img width="600" height="400" src="http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-600x400.jpg" class="attachment-feature-thumb-small size-feature-thumb-small wp-post-image" alt="2017jan_bolo_supplied" srcset="http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-600x400.jpg 600w, http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-300x200.jpg 300w, http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-768x512.jpg 768w, http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-1024x683.jpg 1024w, http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-1100x733.jpg 1100w, http://thegriff.ca/wp-content/uploads/2017/01/2017Jan_Bolo_Supplied-700x466.jpg 700w" sizes="(max-width: 600px) 100vw, 600px" /></a></div><div class="block-content"><h1><a href="http://thegriff.ca/2017/01/fiction-campus-beyond/">Fiction on campus and beyond</a></h1><div class="deck">MacEwan’s Bolo Tie Collective continues to grow after launching first anthology</div><div class="article-meta"><p class="author"><a href="http://thegriff.ca/author/christopher-moreau/" title="Posts by Christopher Moreau" class="author url fn" rel="author">Christopher Moreau</a></p><p class="date"><time class="updated" datetime="2017-01-4" pubdate>January 4, 2017</time></p></div></div></article>								</section>
								<p class="more-link">
									<a href="/most-popular">View Complete List</a>
								</p>
							</div>
						</footer>
					</article>
					
											</div>

			<footer class="footer">
				<nav class="footer-nav">
					<div class="wrap">
												<div class="nav-block">
							<div class="nav-level-1">
								<div class="nav-masthead">
									<p class="tagline">griff, n. (19th c. slang): a tip; reliable information. The Griff is MacEwan University&#039;s student media, est. 2011. Daily online. Monthly in print.</p>
								</div>
								<div class="nav-social">
									<ul>
										<li class="icon-social-facebook"><a href="https://facebook.com/thegriffmag" class="footer-social-facebook">/thegriffmag</a></li>										<li class="icon-social-twitter"><a href="https://twitter.com/thegriffmag" class="footer-social-twitter">@thegriffmag</a></li>										<li class="icon-social-instagram"><a href="https://instagram.com/thegriffmag" class="footer-social-instagram">thegriffmag</a></li>										<li class="icon-social-mail"><a href="mailto:info@thegriff.ca" class="footer-social-email">info@thegriff.ca</a></li>									</ul>
								</div>
							</div>
							<div class="nav-level-2">
								<div class="nav-categories">
									<h2>Categories</h2>
									<ul>
											<li class="cat-item cat-item-4"><a href="http://thegriff.ca/category/campus/" >Campus</a>
</li>
	<li class="cat-item cat-item-2"><a href="http://thegriff.ca/category/culture/" >Culture</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://thegriff.ca/category/downtown/" >Downtown</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://thegriff.ca/category/education/" >Education</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://thegriff.ca/category/events/" >Events</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://thegriff.ca/category/food/" >Food</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://thegriff.ca/category/lifestyle/" >Lifestyle</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://thegriff.ca/category/news/" >News</a>
</li>
	<li class="cat-item cat-item-6080"><a href="http://thegriff.ca/category/newsletter/" >Newsletter</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://thegriff.ca/category/opinions/" >Opinions</a>
</li>
	<li class="cat-item cat-item-6079"><a href="http://thegriff.ca/category/other/" >Other</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://thegriff.ca/category/people/" >People</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://thegriff.ca/category/politics/" >Politics</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://thegriff.ca/category/sports/" >Sports</a>
</li>
									</ul>
								</div>
								<div class="nav-pop">
									<h2>Quick Links</h2>
									<ul>
										<li><a href="/contact">Contact</a></li>
										<li><a href="/about">About</a></li>
										<li><a href="/volunteer">Volunteer</a></li>
										<li><a href="/latest">Latest</a></li>
										<li><a href="/most-popular">Popular</a></li>
									</ul>
								</div>
								<div class="search-block">
									<h2>Search</h2>
									<form role="search" method="get" id="searchform" action="http://thegriff.ca/" >
	<!--<label class="screen-reader-text" for="s">Search for:</label>-->
	<input type="text" value="" name="s" id="s" placeholder="Search the Site..." />
	<input type="submit" id="searchsubmit" value="Search" />
	</form>								</div>
							</div>
						</div>
					</div>
				</nav>
				
<!-- 					<nav class="footer-contact">
					<ul>
						<li><a href="mailto:info@thegriff.ca">info@thegriff.ca</a></li>						<li><a href="tel:(780) 497 5412">(780) 497 5412</a></li>					</ul>
				</nav>
				<nav class="footer-social">
					<ul>
						<li><a href="https://twitter.com/thegriffmag" class="footer-social-twitter">Twitter</a></li>						<li><a href="https://facebook.com/thegriffmag" class="footer-social-facebook">Facebook</a></li>						<li><a href="https://instagram.com/thegriffmag" class="footer-social-instagram">Instagram</a></li>						<li><a href="mailto:info@thegriff.ca" class="footer-social-email">Email</a></li>					</ul>
				</nav> -->
				
				<p class="source-org copyright">&copy; 2017 The Griff</p>
			</footer>
		</div>
				<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://thegriff.ca/wp-content/themes/bones/js/plugins.min.js'></script>
<script type='text/javascript' src='http://thegriff.ca/wp-content/themes/bones/js/scripts.js'></script>
<script type='text/javascript' src='http://thegriff.ca/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201704.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.3',blog:'97302727',post:'26694',tz:'-7',srv:'thegriff.ca'} ]);
	_stq.push([ 'clickTrackerInit', '97302727', '26694' ]);
</script>
	</body>
</html>
